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Summary: 
 

This guide shows how quick and easy it is to achieve a high quality, live multi-
track recording using Yamaha M7CL-48ES, stage-boxes equipped with 

EtherSound, and a Personal Computer. 
An elegant solution can be built using just one cable between mixer and stage, 

and one cable between mixer and recorder (Digital Audio Workstation). 
Such a system is ideal for use as a virtual sound-check tool, and to create a 

concert archive for later mix-down using Steinberg or other professional DAW 
software. 
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Introduction 
 
The live recording solution outlined in this document is the simplest and 
quickest method using a Yamaha digital mixer.  Alongside a standard M7CL-
48ES setup with stage-boxes equipped with EtherSound, just one additional 
cable is needed to connect the computer. 
Using Auvitran’s “Network ASIO Streamer”, the audio signals from the stage-
boxes are routed via the M7CL-48ES 3rd port to the computer’s Ethernet 
adapter.  No additional hardware is required.  Apart from the recording 
software and the ASIO streamer, no additional software is needed: the setup 
can be made from the mixer’s touch-screen.  For additional information about 
“Network ASIO Streamer”, please visit Auvitran’s website: www.auvitran.com . 
 
 
 
Equipment List 

 
Auvitran’s “Network ASIO Streamer” will only work with a small number of 
EtherSound devices that are equipped with a 3rd port.  V3.5 firmware for 
M7CL-48ES introduces this feature to Yamaha products.  Here is a list of the 
equipment necessary for a simple live recording / playback system: 

1. Yamaha M7CL-48ES with v3.5 (or later) firmware.  Also, the internal 
EtherSound module must have firmware 0x0C18 or later. 

2. A 48-input stage-box system with EtherSound connection, such as 3x 
SB168-ES. 

3. One PC running Windows Vista or Windows 7 (32-bit or 64-bit version) 
equipped with a Gigabit Ethernet adapter.  A dual core CPU with a 
clock speed greater than 2GHz is strongly recommended, with at least 
2GB of RAM, and a high-speed storage disk (such as 7200rpm). 

4. Steinberg Cubase 5 or Nuendo 5 software. 
5. One CAT5e or CAT6 cable from the M7CL-48ES “3rd port” to the PC, 

maximum of 100 metres long. 
 
Computer Requirements 
It is strongly recommended to use a computer running Windows 7, with at 
least 2GHz processing speed, and at least 2GB RAM.  Also a Hard Disk Drive 
with a speed of 7200rpm or faster is recommended for recording and playback 
of more than 16 channels at 48kHz 24-bit. 
 
As an example, a PC running Windows 7 (32-bit) with a 2.66GHz Intel® 
Core™2 Quad CPU (Q9400), 4GB RAM, a 7200rpm Seagate disk drive, and 
a Broadcom NetXtreme Gigabit Ethernet adapter, could manage 64 tracks of 
recording and playback with Nuendo 5. 
A notebook PC running Windows 7 (32-bit) with a 2.2GHz Intel® Core™2 Duo 
CPU (T7500) processor, 2GB of RAM, a 7200rpm disk drive, and a Intel® 
82566MM Gigabit Ethernet adapter is also capable of 64 tracks of reliable 
recording and playback.  Other laptops with a similar spec may not work so 
well, depending on the performance of their Ethernet adapters and drivers. 
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With regard to disk storage, allow 500MB per hour for each mono track at an 
audio quality of 48kHz 24-bit.  So for example, 120GB will be able to record 
60 tracks for 4 hours.  Or for a 2 hour show consisting of 48 tracks, allow 
50GB of storage. 
 

Tip: 
Multi-track recording can be a very demanding task for a computer. To 
ensure high quality and reliability, it is best to use a computer dedicated 
to this purpose, without any unnecessary software or drivers installed. 
Tips for optimizing the computers’ performance are listed on page 7. 

 
 
 
Hardware Setup 
 
Setup the M7CL-48ES with the stage-boxes (such as SB168-ES x3) in the 
normal way, using either an EtherSound ring or a daisy-chain.  See the 
“M7CL-48ES Auto Configure Guide” on Yamaha’s website for an example: 
http://www.yamahaproaudio.com/training/self_training/index.html . 
 
Then, using a CAT5e or CAT6 cable, connect the computer’s Gigabit Ethernet 
port to the M7CL-48ES’s “3rd port”, located on the rear panel. 

 
Typical system connection. 

 
Auvitran’s “Network ASIO Streamer” can be downloaded from 
http://www.auvitran.com , with release notes, installation instructions, and 
configuration tips. 
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M7CL-48ES Setup 
The ASIO Streamer function is switched on/off in the main Setup menu on the 
mixer’s touch-screen.  It has two modes: “FROM STAGE BOX” and “FROM 
DAW”.  These two modes automatically set the audio channel routing as 
described below. 

 
A portion of the SETUP menu of M7CL-48ES. 

 
FROM STAGE BOX 
This mode is for live recording.  When “From Stage Box” is selected, the 48 
channels arriving at the mixer from the stage box are also forwarded through 
the “3rd Port” to the computer. 
In addition, the first 16 channels sent by the M7CL-48ES back to the Stage 
Boxes are also forwarded through the “3rd Port”, appearing on the computer 
as inputs 49-64.  This enables sub-groups and effect returns, or the complete 
stereo mix to be recorded, for example. 

 
ASIO Streamer: “From Stage Box” mode. 
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FROM DAW 
This mode is for playback.  When “From DAW” is selected, the first 48 output 
channels from the computer’s Digital Audio Workstation software are 
transmitted through the “3rd Port” to the M7CL-48ES inputs, replacing the 
Stage Box inputs.  The console’s patch settings do not need to be changed.  
This can be useful as a “Virtual Soundcheck”: the console outputs are still 
sent to the Stage Box. 

 
ASIO Streamer: “From DAW” mode. 

 
 
 
“Network ASIO Streamer” Setup 
 
Download and install “Network ASIO Streamer”.  The latest version can be 
found at http://www.auvitran.com , with release notes, installation instructions, 
and configuration tips.  There are no license or registration procedures to 
follow: just a simple installation.  Remember that Mac operating systems do 
not support ASIO.  Only Windows Vista and 7 can be used as the operating 
system. 
 
In the Settings tab of the AVS-Asio Control Panel, it is recommended to set 
the Buffer to the maximum available size (2048) to start with.  This will 
increase latency, but will provide maximum stability.  Actually, there is no 
audio monitoring facility while recording with this system, so any input/output 
latency is not an issue. 
 
Select the required Gigabit Ethernet port in the “Network adapter” menu, and 
the correct M7CL-48ES device should automatically be selected below. 
 
Lastly, choose the required I/O count and click [OK].  The options are 2x2, 4x4, 
8x8, 16x16, 32x32 and 64x64.  Some lower powered computers will struggle 
with high channel counts, so in some cases a lower option will be needed. 
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To maximise the Network ASIO Streamer performance on the computer, here 
are some tips: 

 

1.  Open the “Local Area Connection” 
properties (found in Control 
Panel>Network and Internet>Network 
Connections), and disable all items 
except for the Network ASIO 
Streamer (as shown on the right).  
Note that this will cause connection to 
other networks to stop functioning 
correctly until the original settings are 
re-applied. 
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2.  In the “Local Area Connection 
Properties”, click the [Configure] 
button for the network connection. 
In the Advanced tab, disable (or 
turn Off) the “Interrupt Moderation” 
or “Interrupt Throttle Rate” 
property. 
Disabling this function in particular 
can improve the consistency of 
audio playback in FROM DAW 
mode. 
(note that these properties 
windows might be arranged 
differently for other makes of 
driver / network connection). 
 
3.  Close any unnecessary 
applications on the computer.  
Even any EtherSound software 
such as AVS-ESMonitor should 
be closed to save resources: it is 
not needed for this system 
anyway. 
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Nuendo 5 / Cubase 5 Setup 
 

Device Setup 
The setup procedures for Nuendo 5 and Cubase 5 are virtually identical.  The 
pictures in this section are from Nuendo 5. 
 
After starting Nuendo 5 (or Cubase 5), open the “Devices” menu, and select 
“Device Setup…” 

 
 
Click on “VST Audio System” in the left column, and select “AuviTran ASIO” 
for the ASIO Driver on the right side of the window. 

 
 
By highlighting the sound-card’s name in the left column, the device’s control 
panel can be accessed with a button to the right.  Also, the state of each input 
and output is shown.  At this stage, most i/o will probably be “Inactive” 
because they have not yet been assigned to the project. 

 
www.yamahaproaudio.com 

9



Yamaha Commercial Audio 
Live Recording with M7CL-48ES 

Templates 
When opening a new project in Nuendo 5, the user is offered the chance to 
open either a template or an empty project.   

 

In Cubase 5, the “Project 
Assistant” window may 
appear when opening a new 
project (depending on the 
preferences).  In that case, 
the user templates and an 
empty project are listed in 
the “More” category. 

Cubase 5 “Project Assistant” 
 
A Nuendo or Cubase template is a file which contains all relevant set up data 
for a project.  When opened, it allows the user to instantly start working on a 
suitable project without having to configure a long list of settings from different 
menus and windows. 
 
A template has been created to accompany this document, for live recording 
using Nuendo 5 or Cubase 5 and the Auvitran Network ASIO Streamer.  
(They are free to download from 
http://www.yamahaproaudio.com/training/self_training/index.html).  There are 
templates for 32-track and 64-track recording.  Each one will record 48kHz 24-
bit “Wave 64” files.  (The “Wave 64” format is able to cope with recording over 
long periods of time, creating large file sizes).  This audio file type is easy to 
transfer between Cubase and Nuendo projects.  However, the file format may 
need to be changed to allow compatibility with other audio editing software.  
More details are included in the Appendix. 
 
A method for creating a new template is outlined in the Appendix.  Here 
follows the procedure for opening an existing template: 
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Paste the required templates to the “Project Templates” folder.  The full 
file path is shown below: 

 
C:\Users\<user name>\AppData\Roaming\Steinberg\Nuendo 
5\Project Templates 

 
The Cubase 5 templates should be pasted to a similar location, but in 
the “Cubase 5\Project Templates” folder instead.  There is also a 
shortcut in the Windows “Start” menu for this location. 

 
To open a template in Cubase 5 or Nuendo 5, open the File menu and select 
“New Project”.  Then select the required template from the list.  Easy! 

  

Open the Windows “Start” 
menu, and select the 
“Steinberg Nuendo 5” 
folder from the Programs 
menu.  Then select the 
“Nuendo Application Data 
Folder” shortcut. 
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Start Recording 
This procedure is the same for Nuendo 5 and Cubase 5.  The pictures below 
show Nuendo 5, but the operation of Cubase 5 is almost identical.   
 
Before recording, check that the M7CL-48ES ASIO Streamer function is in 
“FROM STAGE BOX” mode.  This is found in the main SETUP menu of the 
console. 
 
To prepare Nuendo/Cubase 5 for recording, switch on the “Monitor” function 
for the main folder.  This will turn the speaker icons orange for all the tracks.  
That causes the DAW to show the input level meters for each track.  Then 
click on the “Record Enable” button for the folder, so all the “Record Enable” 
buttons turn red. 

 
 

Then, to start recording, click on the “Transport Record” button in the toolbar. 

 
 

To stop recording, press the [Space] bar on the keyboard (or click the “Stop” 
button in the Transport area of the toolbar.  Then save the project (select 
“Save” in the File menu). 
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Playback 
After recording, and before playback, switch off the “Record Enable” and 
“Monitor” buttons in the Folder. 
 
Check that the M7CL-48ES ASIO Streamer function is in “FROM DAW” mode.  
This is found in the main SETUP menu of the console. 
 
Move the play-marker to the required position by clicking in the “time-line”.  
Then click the “Play” transport button (or press the [Space] bar). 

 
 

Remember that only channels 1-48 can be played back through M7CL-48ES, 
due to the number of input channels on the console. 
 
And that completes the instructions: possibly the simplest and quickest way to 
achieve live multi-track recording! 
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Appendix 
 
Create a new Nuendo / Cubase Template 
If the same project settings need to be used regularly, it is convenient to make 
a new Template.  This procedure is the same for Cubase 5 and Nuendo 5.  
(The pictures in this section are from Nuendo 5).  Open the File menu and 
select “New Project”.  If the Templates window opens, select “Empty” and 
click [OK].  Browse for a folder to save the audio and data files. 
 
Go to the Devices menu and select “VST Connections”. 

 
 
Select the “Inputs” tab and delete any buses that are shown: right-click on 
their name and select “Remove Bus”.  Then click the [Add Bus] button and 
select 64 mono buses (or as many as are required) and click [OK]. 

 
 
Do the same for the “Outputs”: 

 
www.yamahaproaudio.com 

14



Yamaha Commercial Audio 
Live Recording with M7CL-48ES 

 
 
The VST Connections window can now be closed. 
 
Open the “Project” menu and select “Project Setup…” 
Select the length of the project (for example, 2 hours and 30 minutes). 
Select the Sample Rate and Bit Resolution (48kHz, 24-bit in this example), 
and the Record File Type (this selection is important if the recording needs to 
be compatible with other audio editing software:  both “Broadcast Wave File” 
and “AIFF File” types can be imported into Pro Tools for example).  Then click 
[OK] to close the window. 

   
 

Back in the “Project” menu, select “Add Track” and then “Folder”. 
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And now in the “Project” menu, select “Add Track” followed by “Audio”.  
Choose 64 Mono tracks (or as many as are needed), and click [Add Track]. 

 
 
Now all the audio tracks need to be moved into the folder so that they can all 
be controlled together:  click on the first track (called “Audio 01” by default), 
then scroll down to the bottom, hold [Shift] and click on the last track.  All the 
audio tracks should now be highlighted.  Scroll back up to the top, then click-
and-drag “Audio 01” into the folder. It should temporarily show a green arrow, 
and all the other tracks will follow into the folder. 

 
 
Next each track needs to be assigned an input and an output from the bus list 
created in the “VST Connections” window.  Obviously it makes sense to 
assign “Mono In 1” and “Mono Out 1” to track 1, “Mono In 2” and “Mono Out 2” 
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to track 2 and so on…  These assignments can be made in the left column of 
the project window when the “Inspector” is enabled in the “Set up Window 
Layout” menu (click the button indicated below or press [Shift+F2]). 

  
 

 
 
It will take a while to assign all 64 tracks, selecting each in turn, but it only 
needs to be done one time.  Once completed, a “template” can be saved for 
future projects. 
 
To save a project template, open the “File” menu and select “Save as 
Template…” then type a name and click [OK].  Then, whenever a new project 
is created, the template can be opened to instantly be ready for recording. 

 

Check the “Inspector” option, to view 
the channel information on the left 
side of the project window. 
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